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Kde kryptografie pom áhá

1. Důvěrnost dat
2. Integrita dat
3. Autenticita dat (integrita a ověření původu)
4. Nepopiratelnost
5. Autentizace a autorizace uživatelů/strojů
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Symetrick á kryptografie

� Symetrická kryptografie
● (správněji kryptografie se symetrickým klíčem)
● stejným (tajným) klíčem se šifruje i dešifruje
● (algoritmus šifrování a dešifrování nemusí být ale 

identický)

Šifrovací

algoritmus

Dešifrovací

algoritmus

Tajný klíč

Otevř. text Zašifr. text Otevř. text

Převzato z: Network and 
Internetwork Security (Stallings)
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Asymetrick á kryptografie

� Asymetrická kryptografie
● pracuje se se dvěma klíči (soukromým a veřejným)
● veřejný klíč mají všichni, soukromý klíč jen jeden

� Co „transformujeme“ veřejným klíčem lze 
„odtransformovat“ jen privátním klíčem
● šifrování pro konkrétního jedince

� Co „ transformujeme“ soukromým klíčem lze 
„odtransformovat“ veřejným klíčem
● podepisování konkrétním jedincem



www.buslab.orgPraktická kryptografie a nástroje, 15.4.2011

Šifrovací

algoritmus

Dešifrovací

algoritmus

Bobův veřejný klíč

Otevř. text Zašifr. text Otevř. text
Alice

Bobův privátní klíč

Bob

Převzato z: Network and 
Internetwork Security (Stallings)

Schéma šifrov ání veřejným klíčem
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Symetrick á kryptografie - DES

� DES (Data Encryption Standard)
● IBM+NSA, 1977
● 56bitový klíč (72,057,594,037,927,936 možností)
● algoritmus veřejný, ale některé části bez zdůvodnění

� Základem je runda obsahující
● přimíchání klíče (xor)
● substituční část
● permutační část

� Využívá tzv. Feistelova schéma
● opakování základní rundy (16x)

� Stále široké využití
● banky (3DES), starší systémy
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EFF DES cracker (1998)

� Krátký klíč DESu kritizován od počátku
● vláda i firmy ale mají tendenci ignorovat

� Praktická demonstrace zranitelnosti
● Electronic Frontiers Foundation (EFF)
● hrubou silou zkouší všechny možnosti klíče
● 4.5 dne/klíč

� Předpokládá se existence zařízení schopného hledat klíč
v téměř „reálném čase“ (NSA)

� Délku klíče lze řešit pomocí tří DESů za sebou (3DES)
● blok je zašifrován třikrát různými klíči
● stále široce používané
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Čas pot řebný pro prohled ání prostoru 
možných klí čů (sym . krypt.)

2.15 ms232 = 4.3 x 10932

5.9 x 1030 let2168 = 3.7 x 1050168

5.4 x 1018 let2128 = 3.4 x 1038128

10 hod256 = 7.2 x 101656

Čas potřebný při 106

dešifrování/µs
Počet možných klíčůDélka klíče 

(bit)
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Symetrick á kryptografie - AES

� AES (Advanced Encryption Standard)
● tříkolová soutěž NIST, vybrán Rijndael (Belgie)
● 128/196/256 bitů klíč, 16 bajtů blok
● velice rychlý v SW i HW, zdůvodnění návrhu

� Základní runda je opakovaná 10x (14x pro delší klíče)
� Hrubou silou už nelze projít celý prostor klíčů

● může ale existovat nedokonalost algoritmu, která prostor sníží
● kryptoanalýza
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Runda algoritmu AES
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Šifrov ání dat na disku – TrueCrypt 6.3a

� Volně dostupný nástroj pro transparentní šifrování dat na 
disku www.truecrypt.org
● data na disku jsou vždy šifrovaná
● dešifrovaná data pouze v RAM paměti

� Hlavička disku obsahuje dlouhý klíč zašifrovaný heslem 
uživatele
● lze použít dodatečné klíčové soubory nebo čipovou kartu  

� Lze šifrovat systémový disk i přenosná média
● nejčastěji ale šifrován soubor připojitelný jako virtuální disk 

� Ideální pro použití na přenosných počítačích
● ztráta počítače nevede k vyzrazení dat
● dobrá ochrana proti zvědavým dětem/rodičům ☺
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TrueCrypt – test rychlosti algoritm ů

� Spuštění testu
� Tools->Benchmark

� AES, Twofish, Serpent + jejich kombinace 
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Srovn ání rychlosti algoritm ů

� http://www.cryptopp.com/benchmarks.html
� Intel Core 2 @ 1.83 GHz procesor

13 Mb/sec, 3DES

rychlostAlgoritmus

12.8 Mb/secRSA 1024bit 
(veřejný klíč)

0.7 Mb/secRSA 1024bit 
(soukromý klíč)

139 Mb/sec, AES 128bit
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TrueCrypt – praktick é cvi čení

1. Instalace, spuštění
� systémový ovladač (administrátorské práva) 

2. Vytvoření nového virtuálního disku 
� Tools->Volume Creation Wizard
� encrypted file container
� standard TrueCrypt volume
� umístění souboru s virt. diskem
� šifrovací algoritmus
� velikost disku
� heslo pro přístup,sběr entropie
� formátování

3. Připojení disku
� výběr volného písmenka
� soubor s virtuálním diskem
� mount, zadání hesla
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� Asymetrická kryptografie
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Digitáln í podpis

� Jedna ze stěžejních aplikačních oblastí
kryptografie

� Využití asymetrické kryptografie k podpisu ale 
zjištěno až po letech znalosti principů šifrování

� Pouze majitel privátního klíče může vytvořit 
podpis

� Podpis mohou verifikovat všichni pomocí
veřejného klíče
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Digitáln í podpis bez certifik átu - naivn ě

1. Alice si vygeneruje dvojici veřejný-soukromý klíč
2. Alice zveřejní veřejný klíč

� cokoli co lze ověřit tímto klíčem jsem podepsala

3. Bob si stáhne veřejný klíč
4. Bob může nyní může ověřit podpis od Alice

� Problém?
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Alice
Podpis

Digitáln í podpis – naivn í řešení

Milý Bobe,

pošli mi prosím 
slíbený milión na 
účet 123456123456

Alice

Alice -
privátní klíč

Bob

Alice -
veřejný klíč
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Podpis

Digitáln í podpis – problém?

Milý Bobe,

pošli mi prosím 
slíbený milión na 
účet 66666666666666

Alice

Eva -
privátní klíč

Bob

Eva -
veřejný klíč

Eva
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Digitáln í podpis bez certifik átu - lépe

1. Alice si vygeneruje dvojici veřejný-soukromý klíč
2. Alice předá osobně veřejný klíč Bobovi

� cokoli co lze ověřit tímto klíčem jsem podepsala já

3. Bob může nyní může ověřit podpis od Alice
4. Eva už nemůže podstrčit svůj klíč

� Bob již veřejný klíč od Alice má

� Problém: co když Alice nemůže dát klíč osobně?
� neznají se (znáte pana Seznama a pana Googla?) 
� geografická vzdálenost...
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Alice
Podpis

Certifik át veřejného klí če

Alice -
privátní klíč

CertifikCertifik áátt
AlicinAlicin veveřřejnýejný
klkl ííčč

Bob

Milý Bobe,

pošli mi prosím 
slíbený milión na 
účet 123456123456

Alice
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Certifikační autoritaUživatelské info

Co je certifikát?

Jméno

Společnost

...

Jméno

Společnost

...

Certifikát

Veřejný klíč

podepsáno CA 
privátním klíčem

informace o 
CA + veřejný 

klíč CA
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Co je certifik át?

� Balík dat podepsaný certifikační autoritou
● veřejný klíč
● majitel certifikátu
● povolené použití klíče
● rozsah platnosti
● použité algoritmy
● další info...
● podpis autority
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Detaily certifik átu 

� Firefox
● Tools→Options → Advanced
● Encryption → View certificates 

� Internet Explorer
● Tools→Internet Options
● Content →Certificates
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Digitáln í podpis s certifik átem (PKI)
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Kdo m ůže dělat certifika ční autoritu?

� V zásadě kdokoli ☺
� Problém je v důvěře

● Bob musí věřit autoritě, že Alici dobře zkontrolovala
● Bob musí věřit autoritě, že neudělala v procesu chybu
● Bob musí věřit, že autorita nebyla ovládaná útočníkem
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Problémy s certifik áty I.

� Certifikát musí někdo důvěryhodný vystavit
● např. placená autorita (I.CA, Verisign, Comodo...)

� Jak moc je důvěryhodná?
● 15. března 2011 kompromitována autorita Comodo

� Vydány falešné certifikáty pro tyto domény
● mail.google.com
● login.yahoo.com
● login.skype.com
● login.live.com
● ...

� Útočník se nyní může vydávat za tyto servery
● klíče revokovány, ale...
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Problémy s certifik áty II.

� Jakým řekneme, že autoritě věříme?
● zkuste jít na https://buslab.org

� Velké množství stránek není certifikováno
● uživatel odklikne bez rozmyslu 
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Problémy s certifik áty III.

� Kterým autoritám vlastně věříme?
� Předinstalované certifikáty v OS/prohlížeči

● v současné době desítky autorit 
● některé přímo kontrolovány různými vládami... 
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Šifrov ání a podepisov ání data komunikace

� Cílem je buď utajit obsah zprávy nebo zajistit autentičnost 
původu dat (nebo obojí) 

� Pretty Good Privacy www.pgp.com
● nyní komerční produkt, některé části stále volné

● PGP Desktop Trial Software
● generování vlastního páru klíčů, správa uživatelů, šifrování, 

podepisování mailů, podepisování software... 

� GnuPG - volná verze, kompatibilní s PGP www.gnupg.org
� Lze integrovat do poštovního klienta

● Thunderbird + Enigmail + GPG (enigmail.mozdev.org )
● MS Outlook + PGP Mail
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PGP/GPG – symetrick é šifrov ání

1. Stažení GnuPG 1.4.10 (www.gnupg.org)
2. Zašifrování souboru symetrickou šifrou (např. AES)

� gpg.exe --cipher-algo AES -c test.txt
� zadání šifrovacího hesla/klíče 
� vznikne soubor test.txt.gpg

3. Dešifrování souboru symetrickou šifrou
� gpg.exe --cipher-algo AES -d test.txt.gpg
� zadání šifrovacího hesla/klíče  

� Soubor test.txt.gpg je při opakovaném šifrování stejným 
klíčem různý – proč?
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PGP – praktick é cvi čení (vlastn í klíč)

1. Vygenerovat pár vlastních klíčů
� File → New PGP Key
� volitelně Advanced Key Settings a délka klíče
� zadání hesla, které bude chránit privátní klíč na disku 

2. Export veřejného klíče do souboru
� Klíč → Export → soubor.asc
� (lze včetně privátního klíče, typicky NEděláme)

3. Zobrazení/publikace souboru veřejného klíče
� soubor.asc (BASE64, notepad)

� http://pgp.mit.edu/ → Submit a key
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PGP – praktick é cvi čení (cizí klí č)

1. Stažení cizího klíče
� http://pgp.mit.edu/, Petr Svenda, 0x89CEB31C

2. Import klíče
� File → Import → soubor.asc

3. Kontrola fingerprintu
� osobně, vizitka, telefon
� A890 0285 D837 AEBB B522  771E 86E8 F87A 89CE B31C

� poté Import

4. Nastavení důvěry
� Key properties → Trust → Trusted

5. Podpis (certifikace) cizího klíče
� Klíč → Keys → Sign...
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PGP – Šifrov ání a podpis souboru

1. PGP Zip → New PGP Zip
2. Přidat soubory určené k šifrování
3. Volba Recipient Keys (šifrujeme pro někoho)

� výběr adresáta: Petr Svenda petr@svenda.com

4. Výběr podepisovacího klíče (podepisujeme my)
� Finish (zadání hesla k našemu soukromému klíči)

5. Vzniká nový soubor s příponou *.pgp
� podepsaný námi (nikdo jiný nemohl vytvořit)
� šifrovaný pro Petra Svendu (nikdo jiný nemůže číst) 

6. Dvojklikem na zašifrovaný soubor se ověří
podpis a dešifruje
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Digitáln í podpis - shrnutí

� Nezajišťuje důvěrnost (tam použijeme šifrování)
� Nejznámější algoritmy – RSA, DSA
� Asymetrické algoritmy jsou relativně pomalé

● cca 10-100x pomalejší než symetrické

� Proto se podepisuje haš – „otisk dat“
� Fáze postupu:

● Vytvoření a registrace klíčů (certifikát)
● Vlastní podepsání

●Dokument → haš → podpis
● Ověření podpisu



www.buslab.orgPraktická kryptografie a nástroje, 15.4.2011

Anonymn í brouzd ání

� Význam ochrany soukromí
● ochrana před represivními režimy (cenzura)
● ochrana vlastních údajů před cílenou reklamou (dělají firmy)
● ochrana před profilováním (dělají i naše vlády)
● základní občanské právo

� Kde vůbec zanecháváme stopy o brouzdání?
● vlastní počítač
● připojení v lokální síti
● připojení k internetovému poskytovateli (ISP)
● směrovače v Internetu
● cílový server 
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Soukrom é brouzd ání – Internet Explorer

1. Historie navštívených stránek
� prozrazuje velmi mnoho
� lze vymazat

2. Obsah cache prohlížeče
� uživatelský_profil\Local Settings\Temporary Internet
� soubory včetně přípony – obrázky, fotky, 

dokumenty…

3. Safety->InPrivate browsing
� není uchována historie, cache, cookies…
� ale pořád dost informací

� viz. http://www.getip.com/
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Soukrom é brouzd ání – Mozilla Firefox

1. Historie navštívených stránek
2. Obsah cache prohlížeče

� uživatelský_profil\Local Settings\Application 
data\Mozilla\Firefox\Profiles\jmeno_profilu.default\Cache\

� soubory přejmenovány, bez přípony
� původní obsah ale obsažen (údaj v hlavičce)
� např. přejmenovat vše na *.jpg a zobrazit

� cmd.exe copy * *.jpg

3. Tools->Start private browsing
� bez historie, bez cache... (jako IE)
� problém s informacemi na serveru zůstává
� ip-check.info



www.buslab.orgPraktická kryptografie a nástroje, 15.4.2011

http://www.getip.com
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JAP (http ://www.jondos .de)
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JonDo – praktick é cvičení

1. Instalace
● JonDo (proxy), JonDoFox (upravený Firefox)

2. Spuštění JonDo proxy
● připojení k volným kaskádám

3. Spuštění JonDoFoxu
● standardní Firefox, proxy na JonDo
● vypnutý JavaScript, reklamy…

4. Test anonymity
● http://www.getip.com/
● vypnutí/zapnutí proxy
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Možnosti profilov ání uživatel ů – proč

� Uživatelé si neuvědomují množství informací o 
nich dostupných

� Uživatelé většinou předpokládají nedostupnost 
privátních informací sdělených jen "přátelům"

� Praktické vyzkoušení si možnosti profilovat třetí
osobu vede k lepšímu uvědomění si problému a 
přiměřenějšímu publikování/chování na Internetu 
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Možnosti profilov ání uživatel ů - základ

� Postupně budujeme a upřesňujeme profil osoby
● pozor na duplicity ve jménech

1. Základní hledání na google.com
● vytvoříme si základní profil uživatele
● poznačíme si možné nejasnosti

2. Veřejně dostupné fotky na images.google.com
● obličej? fotky z akcí? 

3. Základní údaje v informacích Skype, ICQ... 
● lidé neradi uvádí chybné informace
● datum narození... 
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Profilov ání – dobrovoln é informace

4. Domácí stránka, vlastní blog...
● lidé mají tendenci dát světu najevo, jak jsou „dobří“
● většinou se nedozvíme „špatné věci“

5. Starší verze stránek na archive.org
● postupem času zmoudří a odeberou některé

informace (odebrané dokumenty, starší fotky...)
● Wayback machine – archiv stránek a dokumentů

webu

6. Blogy kamarádů a známých
● nejvíce pikantních informací o vás napíšou přátelé
● navíc jsou to často informace, které původní osoba 

považuje za neveřejné
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Profilov ání – sociáln í síť

� Dříve složitější hledání v předchozích zdrojích
● např. seznamy absolventů školy → spolužáci

7. Facebook – zlatá studnice ☺
● fotky, zájmy, vzdělání, 
● síť známých typicky zobrazena, i když nejsme přátelé

8. Náhodně vymyšlená osoba s návrhem přátelství
● spousta lidí má ráda hodně přátel

9. Falešný profil reálné osoby návrhem přátelství
● spolužák ze základky, který ještě není v přátelích
● pomůže nějaká fotka (případně špatně čitelná)  
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Shrnutí

� Symetrická vs. asymetrická kryptografie
● asymetrická kryptografie není řešením všech problémů

� Šifrování disku – TrueCrypt
● virtuální disk v souboru

� PGP/GPG
● symetrické i asymetrické šifrování

� Soukromé data v prohlížeči – IE, Firefox
● historie, cache

� Opravdu anonymní brouzdání – JonDo
● server neví, kdo s ním komunikuje

� Ochrana soukromí je reálný problém
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Otázky
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Škodlivý software

� Virus, červ, trojský kůň, …
� Adware

● cílem je stahovat a zobrazovat uživateli reklamy
● sledování reklam je často alternativa, jak platit za používání

programu
● ne vždy úplně škodlivý
● RealPlayer, Kazaa…

� Spyware
● program, jenž shromažďuje data o uživateli

● hesla, historii brouzdání po internetu…
● keyloggers
● tracking cookies
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SpyBot S&D – praktick é cvi čení

1. Instalace, spuštění
● http://www.safer-networking.org/

2. Stažení aktualizací
� Search for updates

3. Hledání problémů

� Check for problems
� (běží delší dobu)
� pouštět cca 1x týdně

4. Odstranění nalezených problémů

� Fix selected problems
� tracking cookies, malware…


