]> www.fi.muni.cz Git - evince.git/blobdiff - shell/Makefile.am
[dualscreen] licence fix
[evince.git] / shell / Makefile.am
index b2bc86d8d7eff0133e083d25e6574ca201f17aac..008037e41ecbd0744cf62a645268de6bc131871c 100644 (file)
@@ -1,5 +1,5 @@
 INCLUDES=                                                      \
-       -DDATADIR=\"$(pkgdatadir)\"                             \
+       -DEVINCEDATADIR=\"$(pkgdatadir)\"                               \
        -DGNOMEDATADIR=\"$(datadir)\"                           \
        -I$(top_srcdir)                                         \
        -I$(top_builddir)                                       \
@@ -14,7 +14,6 @@ INCLUDES=                                                     \
        -I$(top_builddir)/libview                               \
        -I$(top_srcdir)/libmisc                                 \
        -I$(top_srcdir)/properties                              \
-       -DGNOMELOCALEDIR=\"$(datadir)/locale\"                  \
        -DGNOMEICONDIR=\""$(datadir)/pixmaps"\"                 \
        -DBINDIR=\""$(bindir)"\"                                \
        -DLIBEXECDIR=\""$(libexecdir)"\"                        \
@@ -25,23 +24,23 @@ INCLUDES=                                                   \
 
 bin_PROGRAMS=evince
 
-libexec_PROGRAMS=evince-convert-metadata
 if ENABLE_DBUS
-libexec_PROGRAMS += evinced
-endif
-
-EV_MEDIA_PLAYER_KEYS_SOURCES = ev-media-player-keys.c ev-media-player-keys.h
-if ENABLE_DBUS
-DBUS_SOURCES = $(EV_MEDIA_PLAYER_KEYS_SOURCES)
-else
-DBUS_SOURCES = $(null)
+libexec_PROGRAMS = evinced
 endif
 
 evince_SOURCES=                                \
        eggfindbar.c                    \
        eggfindbar.h                    \
+       ev-annotation-properties-dialog.h \
+       ev-annotation-properties-dialog.c \
+       ev-bookmarks.h                  \
+       ev-bookmarks.c                  \
+       ev-bookmark-action.h            \
+       ev-bookmark-action.c            \
        ev-application.c                \
        ev-application.h                \
+       ev-dualscreen.h                 \
+       ev-dualscreen.c                 \
        ev-file-monitor.h               \
        ev-file-monitor.c               \
        ev-history.c                    \
@@ -50,7 +49,6 @@ evince_SOURCES=                               \
        ev-keyring.c                    \
        ev-marshal.c                    \
        ev-marshal.h                    \
-       $(DBUS_SOURCES)                 \
        ev-message-area.c               \
        ev-message-area.h               \
        ev-metadata.c                   \
@@ -79,8 +77,12 @@ evince_SOURCES=                              \
        ev-window-title.h               \
        ev-sidebar.c                    \
        ev-sidebar.h                    \
+       ev-sidebar-annotations.c        \
+       ev-sidebar-annotations.h        \
        ev-sidebar-attachments.c        \
        ev-sidebar-attachments.h        \
+       ev-sidebar-bookmarks.h          \
+       ev-sidebar-bookmarks.c          \
        ev-sidebar-layers.c             \
        ev-sidebar-layers.h             \
        ev-sidebar-links.c              \
@@ -91,6 +93,15 @@ evince_SOURCES=                              \
        ev-sidebar-thumbnails.h         \
        main.c
 
+if ENABLE_DBUS
+evince_SOURCES += \
+       ev-media-player-keys.c \
+       ev-media-player-keys.h \
+       ev-presentation-timer.h \
+       ev-presentation-timer.c
+endif
+
+
 evince_LDFLAGS = $(AM_LDFLAGS)
 
 if PLATFORM_WIN32
@@ -104,8 +115,8 @@ evince_LDADD=                                                                               \
        $(top_builddir)/cut-n-paste/gimpcellrenderertoggle/libgimpcellrenderertoggle.la \
        $(top_builddir)/cut-n-paste/smclient/libsmclient.la                             \
        $(top_builddir)/properties/libevproperties.la                                   \
-       $(top_builddir)/libdocument/libevdocument.la                                    \
-       $(top_builddir)/libview/libevview.la                                            \
+       $(top_builddir)/libdocument/libevdocument3.la                                   \
+       $(top_builddir)/libview/libevview3.la                                           \
        $(top_builddir)/libmisc/libevmisc.la                                            \
        $(SHELL_LIBS)
 
@@ -119,23 +130,11 @@ endif
 BUILT_SOURCES = ev-marshal.h ev-marshal.c
 
 if ENABLE_DBUS
-BUILT_SOURCES += ev-application-service.h
-endif
-
-evince_convert_metadata_SOURCES=       \
-       ev-convert-metadata.c
-
-evince_convert_metadata_LDADD=         \
-       $(SHELL_LIBS)
-
-if ENABLE_DBUS
-BUILT_SOURCES += ev-daemon-service.h
-
 evinced_SOURCES=                       \
        ev-daemon.c
 
 evinced_CFLAGS=                                \
-       -DDATADIR=\"$(pkgdatadir)\"                             \
+       -DEVINCEDATADIR=\"$(pkgdatadir)\"                       \
        -DGNOMEDATADIR=\"$(datadir)\"                           \
        -I$(top_srcdir)                                         \
        -I$(top_builddir)                                       \
@@ -150,11 +149,7 @@ evinced_LDADD=                             \
 endif
 
 EXTRA_DIST = ev-marshal.list           \
-       ev-application-service.xml      \
-       ev-daemon-service.xml           \
-       evince-icon.rc                  \
-       $(EV_MEDIA_PLAYER_KEYS_SOURCES)
-
+       evince-icon.rc
 
 ev-marshal.h: $(srcdir)/ev-marshal.list
        $(AM_V_GEN)$(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --header > ev-marshal.h
@@ -163,14 +158,6 @@ ev-marshal.c: $(srcdir)/ev-marshal.list
        echo '#include "ev-marshal.h"' > ev-marshal.c
        $(AM_V_GEN)$(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --body >> ev-marshal.c
 
-DISTCLEANFILES=                        \
-       ev-application-service.h        \
-       ev-daemon-service.h
-
-ev-application-service.h: $(srcdir)/ev-application-service.xml
-       $(AM_V_GEN)dbus-binding-tool --prefix=ev_application --mode=glib-server --output=ev-application-service.h $(srcdir)/ev-application-service.xml
-
-ev-daemon-service.h: $(srcdir)/ev-daemon-service.xml
-       $(AM_V_GEN)dbus-binding-tool --prefix=ev_daemon --mode=glib-server --output=ev-daemon-service.h $(srcdir)/ev-daemon-service.xml
+DISTCLEANFILES =
 
 -include $(top_srcdir)/git.mk